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Three-Year, No-Fault Warranty
SUMMARY OF WARRANTY
AE TECHRON INC., of Elkhart, Indiana (Warrantor) 
warrants to you, the ORIGINAL COMMERCIAL PUR-
CHASER and ANY SUBSEQUENT OWNER of each 
NEW AE TECHRON INC. product, for a period 
of three (3) years from the date of purchase, by 
the original purchaser (warranty period) that the 
product is free of defects in materials and work-
manship and will meet or exceed all advertised 
specifications for such a product. We further war-
rant the new AE Techron product regardless of 
the reason for failure, except as excluded in the 
Warranty.

ITEMS EXCLUDED FROM WARRANTY
This AE Techron Warranty is in effect only for failure 
of a new AE Techron product which occurred within 
the Warranty Period. It does not cover any product 
which has been damaged because of any intentional 
misuse, or loss which is covered under any of your 
insurance contracts. This warranty does not extend 
to any product on which the serial number has been 
defaced, altered, or removed. It does not cover dam-
age to loads or any other products or accessories 
resulting from AE TECHRON INC. product failure. It 
does not cover defects or damage caused by the use 
of unauthorized modifications, accessories, parts, or 
service.

WHAT WE WILL DO
We will remedy any defect, regardless of the reason 
for failure (except as excluded), by repair or replace-
ment, at our sole discretion. Warranty work can only 
be performed at our authorized service centers or at 
our factory. 
Expenses in remedying the defect will be borne by 
AE TECHRON INC., including one-way surface 
freight shipping costs within the United States. 
(Purchaser must bear the expense of shipping the 
product between any foreign country and the port of 
entry in the United States and all taxes, duties, and 
other customs fees for such foreign shipments.)

HOW TO OBTAIN WARRANTY SERVICE
When you notify us or one of our authorized service 
centers of your need for warranty service, you will 
receive an authorization to return the product for 
service. All components must be shipped in a factory 
pack or equivalent which, if needed, may be obtained 

from us for a nominal charge. We will take corrective 
actions and return the product to you within three 
weeks of the date of receipt of the defective prod-
uct, or will make available to you a product of equal 
or better performance on temporary loan until your 
product can be repaired or replaced and returned to 
you. If the repairs made by us are not satisfactory, 
notify us immediately.

DISCLAIMER OF CONSEQUENTIAL AND  
INCIDENTAL DAMAGES
You are not entitled to recover from us any conse-
quential or incidental damages resulting from any 
defect in our product. This includes any damage to 
another product or products resulting from such a 
defect.

WARRANTY ALTERATIONS
No person has the authority to enlarge, amend, or 
modify this warranty. The warranty is not extended by 
the length of time for which you are deprived of the 
use of this product. Repairs and replacement parts 
provided under the terms of this warranty shall carry 
only the unexpired portion of this warranty.

DESIGN CHANGES
We reserve the right to change the design of any 
product from time to time without notice and with no 
obligation to make corresponding changes in prod-
ucts previously manufactured.

LEGAL REMEDIES OF PURCHASER
There is no warranty that extends beyond the terms 
hereof. This written warranty is given in lieu of any 
oral or implied warranties not contained herein. We 
disclaim all implied warranties, including, without 
limitation, any warranties of merchantability or fitness 
for a particular purpose. No action to enforce this 
Warranty shall be commenced later than ninety (90) 
days after expiration of the warranty period.
This statement of warranty supersedes any others 
contained in this manual for AE Techron products.

AE TECHRON INC.  
Customer Service Department

2507 Warren St. Elkhart, IN, 46516, U.S.A.
(574) 295-9495

www.aetechron.com
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1  About the HVR Software
The HVR software is a Windows-based .NET 
application that runs on the tester. The user 
interface has been designed to be used quickly and 
easily for users with experience with the AE Techron 
3110A Signal Wave Generator.

The software architecture is object-oriented and 
designed for long life and maintainability.

It provides the user with integrated device control of 
the various components of the system with minimal 
physical user interaction with those parts.

1.1  Disclaimer
Although AE Techron has made substantial effort 
to ensure the accuracy of the Segment test files, 
which are included with the HVR unit, no warranty, 
expressed or implied, is made regarding accuracy, 
adequacy, completeness, legality, reliability or 
usefulness of the information provided. It is the 
responsibility of the user to ensure the accuracy 
and applicability of these test files for their intended 
purposes.

2  Architectural Overview
The HVR Series Application runs on the HVR 
system and provides the user interface into the 
tester. 

The top of the display has the segment definitions 
and some user controls in the top left, the step 
level data in the top right, and a voltage/current vs. 
frequency chart at the bottom:

Figure 2.1 is actual data, plotted with the E48 step 
type, saved from the testing of reactive load during 
development, exported to a Report through the 
menu, and used as a demonstration for the HVR 
Complete System (CS) (10 Hz to 150 kHz). The 
bow near 100 Hz shows voltage reduced due to 
current limiting. The target line appears in grey.

Controls allow replacing the Voltage and Current 
chart with an Impedance chart calculated for each 
step as voltage/current or a DFT representation of 
the data collected (chart for each step) through the 
menu item “View.”

Figure 2.1 – HVR CS Data with E48
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Figure 2.2 – HVR CS Impedance Data with E48

Figure 2.3 – HVR DFT Data for a Given Step

Figure 2.2 shows the corresponding impedance plot for the HVR CS data shown in Figure 2.1. 

Figure 2.3 shows the corresponding DFT plot for the HVR CS data shown in Figure 2.1.
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Figure 2.4 – HVR RG Data with E48

Figure 2.5 – HVR CS Data with E48 from a Reactive Load

Figure 2.4 shows the same data as Figure 2.1 plotted for the frequency range of the HVR Ripple Generator 
(RG) (200 Hz to 150 kHz).
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2.1  Segment Definitions
Segment definitions are an easy and convenient 
way to describe a test set without needing to define 
each step. The wave forms are simple AC ripple 
riding on top of a DC carrier. The user creates the 
segment definitions based on shared characteristics 
and these definitions are stored in a csv. 

The software creates the steps from the segment 
definitions without user intervention based on the 
step size defined in the Segment file. As a test is 
running, the Segment number is identified at the top 
as the labels turn green. 

Overlaps between Segments are only allowed at the 
endpoint; multiple points may not be overlapped. 
For example, Figure 2.4 shows a point at 1 kHz for 
12 V and one for 24 V. 

The role of the signal generator loads and runs a 
single ripple wave step on command. 

With the Complete System (CS) models, the DC 
Power Subsystem will provide the DC voltage 
as well as the ripple below 200 Hz. The Control 
Program will make the determination of how 
to command the power supply and the signal 
generator as it goes through the steps and the 
transition is seamless.

Feedback for compensation is provided by a 
digitizer within the HVR system, which collects the 
current and voltage data. The time domain data 
captured by the digitizer are analyzed through a 
Discrete Fourier Transform (DFT) process for each 
step to separate out the fundamental frequency 
from the harmonics. The results of the DFT analysis 
are retained for each step and included in the report 
that can be generated at the end of the test.

2.2  Segment File
The creation of a Segment File for a specific set 
of test parameters begins with the user specifying 
these values for a segment of steps that share a 
voltage target, current limit, and frequency step size 
over a frequency range:

Start:	 Ripple Frequency	 10 Hz 
	 AC Amplitude Target	 10 Vp 
	 Current Limit		  50 Ap

	 DC Voltage		  400 VDC

End:	 Ripple Frequency	 1000 Hz 
	 Step Size		  E12, E48, E96 or  
				    Linear with user- 
	 	 	 	 defined step size. 

E12, E48, and E96 are fully supported and display 
nicely on the logarithmic scale. 

The number of segments is unlimited, so the user 
could make complicated test sequences with this 
UI.

2.3  Step Handling
The step is handled during the automated 
compensation process. A manual compensation 
process is envisioned as well (where the user can 
choose data differently than the automation would). 
Safety limits will need to be enacted to keep the 
user from deliberately driving past the current limit 
or the power limits on the DC Power Subsystem.

The compensation/test results will be stored in a file 
through the Reports menu item.
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3  Compensation
3.1  Step Compensation Process
The Step Compensation Process always starts 
with an amplitude of (target/30) as the command 
voltage to the signal generator. This is not equal 
to the voltage at the output of the system, due to 
the impedance dependent frequency response, 
but reflects the first iteration of the compensation 
process.

“Current Limit Danger” is calculated as 
(targetVoltage / CalculatedImpedance >= current 
limit). In other words, assuming the impedance to 
be fixed at that frequency, will the current limit be 
triggered by the target voltage.

If there is no “Current Limit Danger” found, the 
next iteration will apply the amplitude as 90% of 
the target voltage. The step impedance is then 
recalculated to ensure that it has not changed 
or changed within the current limit parameters. 
“Current Limit Danger” is then recalculated with the 
new impedance and, if no danger exists, the output 
amplitude is set to the target at 100%. If not within 
tolerance yet, repeat the iterations until it reaches 
the target within tolerance.

If “Current Limit Danger” is detected on any 
iteration, the system will approach the current limit 
at an amplitude set to reach 60% of the current limit 
and recalculate. The next iteration will be either:

•	 Approach current limit at an amplitude to 
achieve 90% of the current limit (no “Current 
Limit Danger”) and then the amplitude where the 
current limit is triggered.

•	 If still not at the current limit, slowly approach 
until within tolerance or the current limit is 
triggered.

The Step Compensation algorithm was chosen to 
balance speed with caution relative to the current 
limit and the protection of the equipment.

3.2  Network Setup
The HVR tester uses an internal ethernet 
connection and IP configuration to communicate 
between various parts of the system. The HVR 
tester comes from the factory set up in a standalone 
fashion: the internal ethernet network is not set up 
for connection to a customer’s intranet. 

If requested by the customer, AE Techron will 
configure it as public in the factory to reduce the 
inconvenience to the customer at setup.

3.2.1  Private network setup (factory default):

Signal generator internal set up:

•	 IP address – 	 192.168.2.250 (arbitrary)
•	 Gateway -		  192.168.2.0
•	 Network Mask - 	 255.255.255.0
•	 DNS1 - 		  8.8.8.8
•	 DNS2 - 		  8.8.4.4
•	 No changes are needed for the 3110FS file 

share access
•	 Power off and back on

Micro-PC network set up:

•	 IP address - 	 192.168.2.5
•	 Ping the signal generator to confirm the 

connection
•	 Mark ethernet as private in Windows

3.2.2  Public network setup:

Signal generator:

•	 IP address – set internally and changed by 
customer; this should be a static IP address

Micro-PC

•	  IP address - set internally and changed by 
customer

•	 Ping the signal generator to confirm
•	 Reconnect the 3110FS file share drive on the 

3110A client application on the micro-PC
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4  Navigation
The menu at the top provides navigation into the 
various functions of the HVR application. 

4.1  The File Menu Item
Under the File menu item, the “Load Segment File” 
selection opens the Standard Segments folder 
to select an existing Segment File (see Fig. 4-2). 
This folder is read-only, but files can be read in, 
modified and stored into the individual’s user folder. 
The contents of the Standard Segments folder are 
determined by the standards supported.

Under the File menu item, the “Modify or Create 
Segment File” selection can be used to modify and 
save an of the existing Segment Files. It opens a 
new page where data can be entered and modified 
(see Fig. 4-3). 

For ripple testing the start and end amplitude will be 
the same for AC and DC. Where options are limited, 
drop downs are provided. The Step Size Type has 
4 built-in values to select from: E12, E48, E96, and 
Linear. E12 and E48 are the most typical for ISO 
21498 testing.

Under the File menu item for this page, are typical 
file operations:

•	 New file
•	 Open
•	 Save
•	 Save As
•	 Close form

Figure 4.1 – Navigation Menu

Figure 4.2 – File Menu, Load Segment File Window

Figure 4.3 – Modify or Create Segment File Window
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4.2  The View Menu Item
Under the View menu item, the “Voltage/Current 
Chart” is the default selection. During testing, the 
voltage and current are both displayed on this chart 
with the voltage scaled on the left and the current 
scaled on the right (see Fig. 4-4).

Changing the selection changes the chart view at 
the bottom of the page.

Under the View menu item, the “Impedance Chart” 
selection displays the Impedance calculated from 
the voltage and current values on the Voltage/
Current Chart.

Under the View menu item, the “Step DFT 
Histogram” selection shows the results of the DFT 
analysis of the time domain voltage and current 
data. Eight levels of harmonics are displayed.

Figure 4.4 – View Menu

Figure 4.5 – Reports Menu

4.3  The Reports Menu Item
Under the Reports Menu Item, selecting “Generate 
Report to File” will save off the test data for this test 
(see Fig. 4-5). A partially completed test will include 
only the data from the steps that have completed. 
The data file is in a csv format and stored on the 
computer at location C:\3110FS\Reports with a time 
and date stamp (see Fig. 4-6).

The csv file may be opened in Excel for further 
analysis (see Fig. 4-7).

The data includes the initial Segment File 
information for each step along with the captured 
values for voltage, current, and the calculated 
impedance. The voltage and current DFT values 
are included at the end of the row with headings 
like vDFT1 (voltage amplitude at the fundamental 
frequency), vDFT2 (voltage amplitude at the first 
harmonic (fundamental frequency * 2)), and so forth. 
The current DFT is labeled as iDFT1, iDFT2, etc. In 
both cases, the captured value is the amplitude at 
the fundamental frequency.

Figure 4.6 – Generate File Report to File List

Figure 4.7 – Report File Opened in Excel
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Figure 4.8 – Load Connection Message

4.4  The System Calibration Menu Item
The HVR test system comes from the factory with 
System Calibration already performed. The System 
Calibration file is stored on the HVR system and is 
read during the application initialization. The System 
Calibration should be repeated annually after each 
subsystem item is confirmed to be calibrated. 
Selecting this menu item presents this message 
box:

The System Calibration is performed into a 
completely resistive 4 Ω load at 10 pre-determined 
frequencies. Once the System Calibration is 
completed, the step-wise calibration is performed 
during the testing sequence.

Select the System Calibration Menu Item and verify 
that a “Load Connection” message box (see Fig. 
4-8) appears and after confirmation of the 4 Ω load, 
the System Calibration form opens. (See Fig. 4-9).

Figure 4.9 – System Calibration Window

The System Calibration form is opened to 200 Hz 
by default. Each calibration frequency can be cycled 
by the “Next Frequency” and “Previous Frequency” 
buttons.

The Target Value is the target amplitude at the DUT 
for a ripple sine wave at the given frequency. The 
Target Value is pulled from the calibration file on the 
system and would rarely be changed. The Target 
Value is in Vp but also displayed in Vrms.

The Set Value is the amplitude sent to the signal 
generator. The System Calibration function will 
change the Set Value as the System voltage value 
and the Meter reading values change. A message 
will appear when the application has changed the 
Set Value (as shown above). The Set Value is in Vp 
but also displayed in Vrms.

The System voltage value is the amplitude 
measured by the internal digitizer. The System 
voltage value is displayed in both Vp and in Vrms.

The Meter Reading value is entered into the Vrms 
box after checking the inputs to the 4 Ω load and 
noting the Vrms value on the calibrated meter.

The goal of the System Calibration process is to 
produce matching readings between the Target 
Value (Vrms) and the Meter Reading (Vrms). 
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The other data on the page is used during the 
calibration process but is not meaningful during 
normal operation. It might be useful for AE Techron 
Technical Support if a support call is registered 
about the calibration.

The function of the buttons at the bottom are:

•	 “Run System Cal Wave” – after the Meter 
Reading is updated, select this button to re-run 
the calibration cycle. This button is disabled 
when it is not a valid next step (for example if 
a calibration cycle has been run but the Meter 
Reading has not been entered).

•	 “Accept Cal Value” – confirms that the 
calibration cycle is complete. This step can be 
done implicitly by moving to the next frequency.

•	 “Save Cal File” – writes the results of all the 
calibration steps to the System Calibration file. 
This step also invalidates a currently loaded 
Segment File as the file must be reloaded to use 
the new calibration values.

4.5  The Utilities Menu Item
Under the Utilities menu item, the “Reset digital 
ports device” selection can be used if the internal 
controls of the digital ports devices need to be reset 
or re-initialized.

Under the Utilities menu item, “Reset data collection 
device” can be used if the data collection device 
needs to be reset or re-initialized (See Fig. 4-10).

4.6  The About Menu Item
Under the About menu item, the “Network 
Information” selection is used to confirm that the 
HVR system and signal generator devices are 
connected to the network and their respective IPs 
are displayed (see Fig. 4.11).

Figure 4.10 – Utilities Menu

Figure 4.12 – About Menu

Figure 4.11 – Network Information Window

Under the About menu item, the “HVR Series 
Operator’s Manual” selection displays the HVR 
Series Operator’s Manual (see Fig. 4-12).

Under the About menu item, the “HVR Series 
Software Manual” selection displays this HVR 
Software Manual.
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During the running of each step, the output 
amplitude on the ripple is calibrated to provide the 
requested voltage at that frequency. If the DUT 
power circuit resonates at that frequency, the 
current limit will be invoked to protect the testing 
equipment and the voltage will fall below the 
target voltage. This subset of the chart shows the 
resonance around 100 Hz (see Fig. 5-3).

Figure 5.1 – Standard Segments File to Load Window

Figure 5.3 – 100 Hz Resonance Chart

Figure 5.2 – Segment Values Window

Run Button

DC Voltage 
Entry

5  Operation
The HVR Series is designed to require as little 
operator intervention as possible. Therefore, a 
typical test sequence would be:

1.	 Select the Standard Segments file to load and 
run (see Fig. 5-1).

2.	 If the external DC power supply is being set by 
the HVR system, enter the DC voltage into the 
pink box and hit enter (see Fig. 5-2). For more 
details on external DC power supplies, see  
section 5.1.

3.	 Confirm the output of the DC power supply  
(regardless of whether the HVR system is  
controlling it or not).

4.	 Select the Run button and the test will start.
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The achieved amplitude is in green, the applied 
current is in blue, and the target amplitude is in 
grey. As the circuit reaches resonance, the current 
is limited (dark orange) and the amplitude begins to 
drop. This effect is also reflected in the Impedance 
Chart as the impedance is dropping (see Fig. 5-4).

This compensation process was described earlier 
as the “Step Compensation Process.”

The entire test sequence should run without 
further operator intervention unless an issue is 
encountered.

Figure 5.4 – Impedance Chart

5.1  DC Power Supply Control
The HVR test system (HVR 2000RG model) is 
designed to allow users to control the output of an 
external DC Power Supply with an analog output 
from the HVR test system. The analog output is 
identified as DC Power Control on the back panel. 

The analog output is 0–10 VDC and will function 
with most DC Power Supplies. If an external power 
supply is controlled by a different signal, say 0–5 
VDC, it is necessary for the user to account for the 
differences.

The DC voltage setting is in the center of the main 
page (highlighted here in pink):

The HVR 2000RG will control an external power 
supply with up to 2000 VDC output. Entering a 
voltage value between 0 and 2000 into the DC 
voltage box will set the control output of the HVR 
tester to a scaled value between 0 and 10 VDC. 

Figure 5.5 – Segment Values Window: DC Voltage Setting


